【Cisco】CatalystスイッチでVLANの設定・使い方

Ciscoスイッチ(Catalyst)でVLANの設定・使い方についてまとめました。

【VLANとは】概要

VLAN(Virtual LAN)とは、物理的な構成に関係なくグループ化できる機能です。
具体的には、以下のようなことができます。

VLANでできること
1 物理的に本来は1つのLANを仮想的に複数のLANにグループ化(ブロードキャストドメインの分割)
2 物理的に複数のLANを仮想的に1つのLANとして扱う
関連記事
関連 【VLANとは】仕組みを簡単に解説

【VLAN作成】ID、VLAN名

Ciscoスイッチ(Catalyst)でVLANを作成するコマンド例は次の通りです。
※VLAN(ID:10、名前:VLAN10)を作成

Switch(config)# vlan 10
Switch(config-vlan)# name vlan10
Switch(config-vlan)# exit

※スイッチ(VTPモード:サーバーモードの)で作成すれば、同一ドメイン内の全てのCatalystに作成したVLANの設定が反映されます。

【VLAN設定】ポートVLAN、タグVLAN

VLANには、主に以下の4つの方式があります。

方式 概要
ポートVLAN スイッチの接続ポート単位でグループ化
タグVLAN パケット内の拡張タグに指定された情報でグループ化
アドレスベースVLAN MACアドレスもしくはIPアドレスでグループ化
ポリシベースVLAN ネットワークプロトコル(IP、IPX、AppleTalkなど)でグループ化

ポートVLAN

物理インターフェース(Fa0/0)にポートVLAN(ID:10)を設定する例です。

Switch(config)# interface Fa0/0
Switch(config-if)# switchport
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Switch(config-if)# no shutdown
Switch(config-if)# exit
コマンド 概要
switchport インターフェースをレイヤー2に設定(VLANが割り当て可能になる)
※1デフォルト状態で全てのインタフェースがレイヤー2に設定されているスイッチもある(Catalyst2960などはswitchportコマンドがない)
switchport mode access ポートVLANを有効化
switchport access vlan 10 インターフェースでVLAN(ID:10)が使用できるよう設定
no shutdown インターフェースを使えるようにするコマンド

タグVLAN①

物理インターフェース(Fa0/0)にタグVLAN(形式:dot1q)を設定する例です。

Switch(config)# interface Fa0/0
Switch(config-if)# switchport
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# no shutdown
Switch(config-if-range)# exit
コマンド 概要
switchport trunk encapsulation dot1q VLANタグの形式(カプセル化形式)をdot1qに設定。(Cisco以外のスイッチ間でも使用可能
switchport mode trunk インターフェースをトランクポートに設定(タグVLANを使用可能に)

タグVLAN②

物理インターフェース(Fa0/0)にタグVLAN(形式:dot1q、ID:10のみ)を設定する例です。

Switch(config)# interface Fa0/0
Switch(config-if)# switchport
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport trunk allowed vlan 10
Switch(config-if)# no shutdown
Switch(config-if-range)# exit

※「allowed」を「remove」にして実行すると、許可されているVLANから削除できます

【VLANの確認】show vlan brief
「show vlan brief」で設定されたVLANの一覧を表示できます。

Switch# show vlan brief

【VTPの設定】サーバー、クライアント、トランスペアレント、オフ

VTPとは、CatalystスイッチのVLAN設定を、同一ドメインにある他のCatalystスイッチにも自動で配布する機能です。
ここに出てくるドメインとは、DNSのドメイン名ではなく、VTP内で使うドメイン名です。(スイッチ毎にドメイン名を設定できます)
VTPには次の4つのモードが存在します。

モード 概要
サーバー ●VLANの設定ができる
●同一ドメイン内の他のスイッチにVLANの設定を配布する
●同一ドメイン内の他のスイッチ(サーバーモード)で設定されたVLANも反映される
【利用例】
コアスイッチをサーバー、エッジスイッチをクライアントに設定すると、サーバー側だけでVLANを一括設定でき楽になる
クライアント ●VLANの設定ができない
●同一ドメイン内の他のスイッチ(サーバーモード)で設定されたVLANも反映されない
トランスペアレント ●VLANの設定ができます
●同一ドメイン内の他のスイッチにVLANの設定を配布しない
●同一ドメイン内の他のスイッチ(サーバーモード)で設定されたVLANも反映されない
●サーバーからクライアントへの配布は転送する(サーバーとクライアントの途中にトランスペアレントのスイッチがあっても配布できる)
【利用例】
VLANの設定が他のスイッチと違う場合に使用する
オフ ●VLANの設定ができる
●同一ドメイン内の他のスイッチにVLANの設定を配布しない
●同一ドメイン内の他のスイッチ(サーバーモード)で設定されたVLANも反映されない
●サーバーからクライアントへの配布は転送する(サーバーとクライアントの途中にトランスペアレントのスイッチがあっても配布できない)
【利用例】
VLANの設定が他のスイッチと違い、かつ配布を中継したくない場合に使用

サーバー

スイッチのドメイン名を「domainname」、モードを「サーバー」で設定するコマンドです。

Switch(config)# vtp domain domainname
Switch(config)# vtp mode server

クライアント

モードを「クライアント」で設定するコマンドです。

Switch(config)# vtp mode client

なお、スイッチ(クライアントモード)とスイッチ(サーバーモード)を接続すると、スイッチ(クライアントモード)は自動的にドメイン名を取得するため、ドメイン名の設定は不要です。

トランスペアレント

モードを「トランスペアレント」で設定するコマンドです。

Switch(config)# vtp mode transparent

オフの設定

モードを「オフ」で設定するコマンドです。

Switch(config)# vtp mode off
関連記事
1 【Cisco】ルーターの使い方・コマンド集
2 【UNIX入門】コマンド・サンプル集
関連記事